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GSAK (Geocaching Swiss Army Knife) 

 

This document was created for the Speed Caching Event - Hints and Tips 
(http://coord.info/GC4291W) event.  The intention is to give an introduction to GSAK version 8.2.x 
and although a lot of information will still work for other later versions, care should be taken. 

GSAK only runs on Windows operating systems (2000, XP, Vista and Windows 7).  I have not tried 
GSAK on any other operating system and difference may occur is this is attempted due to the way 
that GSAK works internally. 

This document does not go into downloading and installing of GSAK as this is dependent on the 
version of the Windows in use.  If anyone does require help on this, please contact me via my 
Geocaching.com profile. 

If you wish to contact me, you can do so through my Geocaching.com profile (The Tares Clan). 

  

http://coord.info/GC4291W
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1 What is GSAK 

GSAK stands for Geocaching Swiss Army Knife and it is a product which is an all in one Geocaching 
and waypoint management tool which runs on Microsoft Windows operating systems such as 
Windows XP and Windows 7.  It is offline database program and has the ability to use database 
commands directly. 

It allows you to import Geocache information via various methods and then manipulate it in many 
ways which can be a benefit you when searching for caches. 

IMPORTANT To get the best use of GSAK, you require a Premium Membership at 

Geocaching.com.  Everything will still work if you are a standard member 

but you will be severely limited in updating information.  This is not a 

limitation of GSAK but something that is enforced by Groundspeak. 

1.1 Major Features 

The following are some of the major features of GSAK that all cachers are likely to find useful.  There 
are many other features which can be used but are more likely to be needed by a more advanced 
GSAK user. 

 Multiple databases (You can have ne for your finds, your puzzles solved caches, caches near 
your work etc) 

 Sending/receiving waypoints to GPSr/smartphone/tablet 

 Extensive filtering, sorting, and searching capabilities 

 Backup and Restore 

 Customised statistics pages (which can be automatically sent to Geocaching.com) 

 Custom URL's for each waypoint, and waypoints as a group. 

 Export to many formats allowing you to use GSAK data in other programs 

 Add "corrected coordinates" to any waypoint  

 User Notes.  You can also import and export notes in text format  

 Ability to set centre point for calculation of distance and bearing  

 Backup and restore of databases and settings  

 Split screen view with 7 formats:  full waypoint display, google maps, details only, full logs 
only, log summary, online page, or child wayoints. 

 Extendable via an extensive macro language (Macros can be downloaded for free from the 
GSAK website) 

1.2 Licencing 

GSAK is a commercial program but you are able to download and use it for 21 days with full 
functionality.  You may still use GSAK after 21 days but you will get a nag screen which takes longer 
and longer to disappear. 

If you wish to remove the nag screen, registration is required but the author (Clyde England) has 
been very generous with the licencing of it.  Registration costs $30 US Dollars (approx. £19 at time of 
writing this document) but this is a one off fee for a particular major version. Once paid your current 
version of GSAK is registered for life.  Also, all updates to the current major version are free.  For 
example, if you paid for a version 8 registration, version 8.1, 8.2, 8.3, etc will all be free.   
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When Clyde releases a new version, there will be an upgrade cost.  However, Version 7 was released 
on the 30th January, 2007 and Version 8 on 9th November, 2011 so you got approximately four years 
for your registration cost. 

In addition, you can install GSAK on multiple computers and use with multiple GPSrs that you own 
with one license and all settings, databases, etc can be moved between computers without any 
problems. 
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2 Screen Elements 

It is important to understand the various parts of the GSAK screen as I will be using the terms 
throughout this document. 

 

Figure 1 - Screen Elements 

Some of the screenshots may look different from a vanilla installation due to tweaking that I have 
done but hopefully you should be able to make sense of everything  
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3 Initial Configuration 

It is very important that you configure GSAK properly as it uses information in the configuration in 
many ways and if this is wrong, you will get various issues. 

To configure the options, go to the Menu bar and select Tools->Options.  This will show the following 
screen: 

 

Figure 2 - General Options 

The important options are highlighted. 

 Owner ID#.  I have the best results by using the account ID rather than the Exact Match.  This 
is also handy if you change username at Geocaching.com as the user ID will always be the 
same.  You can get your account number by going to http://www.geocaching.com/account/. 

 Distance.  Make sure this is set as Miles unless you are also going to be caching on the 
continent. 

 Automatic Backup.  GSAK can automatically backup up all your databases and settings when 
you exit the program.  GSAK keeps a rolling copy of your most 5 recent backups. The backup 
files are named GSAKAuto1.zip, GSAKAuto2.zip, .... GSAKAuto5.zip 

Now select the Locations tab and you will get a screen similar to the following (I have masked some 
details for privacy reason): 

http://www.geocaching.com/account/
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Figure 3 - Setting Locations 

As can be seen, you can have many locations.  Your primary ones should probably be Home and 
Work.  These are used to help filter caches based on a particular location. 

 

Figure 4 - Advanced Settings 

 Run split screen.  This option is used to suppress any split screen browser messages that may 
pop up. For example, if you view a page that has script errors you currently get a pop up 
message saying that the current page has script errors. 

 Version Check.  This is used to ensure you have the latest version running (if you choose to 
install it).  GSAK’s author is always updating the program and it is normally good to have the 
latest. 

 Language. GSAK can run in multiple languages if you require. 
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4 Data 

The main purpose of GSAK is to store and manipulate Geocaching data.  To allow you to do anything, 
you need to have data in your database.  This can be done by two methods. 

4.1 Loading PQs 

A Pocket Query (PQ) is the original way of generating data which is then imported into GSAK.  
Creation of PQs is out of scope of this document but a goof source of information can be found at 
http://markwell.us/pq.htm.  You need to be a premium member at Geocaching.com to create a PQ. 

Once a PQ has been generated and downloaded to you PC go to the Menu bar and select File->Load 
GPX/LOC/Zip file. 

 

Figure 5 - PQ/GPX Load dialog 

 The folder symbol at the top right hand side of the screenshot is used to allow you to find the 
file which you wish to import. 

 By default, the Use defaults option is ticked but change this to unticked and you will have a 
lot more control over the way that GSAK interacts with the load. 

 Make sure that the Warning is NOT ticked as this will delete everything that is already in your 
database and you will only end up with the information that is contained within the PQ. 

 If you want GSAK to tidy up after itself, you can tick the Delete file(s) option. 

 To begin with, make sure that Show Summary is ticked as it shows some information to you 
after the data is loaded. 

 Some useful options to have set are: 
o County update: Automatically updates your database with county information for 

caches.  Y = Update county and B = only update if blank 
o State Update: Automatically update your database with state information.  S = 

Update State and B = Update if  blank 
o Elevation: Automatically updates the elevation of caches.  There is no need to run a 

separate macro. 

http://markwell.us/pq.htm
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During the loading process, you will see a dialog box similar to the following: 

 

Figure 6 - PQ Loading 

Once the data is loaded (and assuming you had the Show Summary option ticked), you will 
something similar to the following: 

 

Figure 7 - Summary Box 

The Total Numbers shows the overall total waypoints which have been loaded.  If you had selected to 
load a folder in the load dialog rather than a single file, you are able to load multiple PQs at once. 

This area is normally coloured in the same way as the Totals header but if you are at the PQ limit 
(1000), this will turn red.  This is useful if you have created a set of PQs which are date related as you 
will be able to see when it is time to create a new PQ. 

  



Speed Caching Event - Hints and Tips 
(http://coord.info/GC4291W) 

 

 

GSAK Introduction and Tips.docx Page 12 of 43 

 

4.2 API 

One of the benefits of Version 8 of GSAK is that it used the Geocaching.com API (Application 
Programming Interface).  This is simply a way to connect directly to the Geocaching.com website and 
ask it for information which will then be returned to GSAK. 

The benefit if using the API is that it allows you to get more information in addition to any PQs you 
have set to run on Geocaching.com as well.  For premium members the limits are currently 6,000 full 
caches per day (and also 10,000 "lite1" caches). For non-premium members the limits are 3 full 
caches per day (and 10,000 "lite" caches) . 

Before you use this functionality, you must connect your copy of GSAK to your Geocaching.com 
account.  How this is done is shown in section 9.1.  Further details of the API are discussed below. 

Go to the menu bar and select Geocaching.com access and then Get Geocaches: 

 

Figure 8 - Get Geocaches from Geocaching.com 

  

                                                             
1 A full cache can be seen as being the same as having the same information as a .GPX file (ie contains logs etc) 
and a lite is similar to a .LOC file. 
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The following dialog is shown: 

 

Figure 9 - Get Geocaches - Basic Tab 

Remember that we set up locations Figure 3, these are where they can be useful.  You can use your 
location for the center  point or you can use an existing cache as shown here. 

As can be seen, this dialog looks a lot like a PQ questionnaire on the Geocaching.com website but it 
also has some additional features, both on this screen and on the Advanced tab discussed below.  
The main option to care about on this screen is the number of logs to download.  Although you can 
download up to a maximum of 30, you do not always want to do this as it will take longer.  There is a 
facility to download up to 9999 logs which will be discussed in 9.3.5 but this should be used very 
sparingly. 

The Google Map button allows you to draw a rectangle or a circle on a Google map, thereby 
potentially giving a better level of granularity. 

The Advanced tab gives some very handy extras that you cannot do via a PQ. 

 

Figure 10 – Get Geocaches – Advanced Tab 
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 Owned By: only find caches owned by a particular cache owner. 

 Excluded By: Do not download any caches owned by a particular cache owner. 

 Not Found By: Only download caches which have not been found by a particular cacher 

 Data Format: Full gives the equivalent of a PQ GPX file (with the addition that a PQ file only 
has the last 5 logs in it).  Lite is equivalent to a .LOC file and is useful for just check the status 
of a cache. 

 Favorite points: Only download caches which have a certain amount of favourite points. 

The powerful thing about the Owned, Excluded and Not Found fields is that you can link up to a 
maximum of five names.  For example, if I wanted to download caches that had not been found by 
myself and two other cachers, I would put “The Tares Clan,cacher1,cacher2” in the Not Found field. 
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5 Main Screen 

Once some data has been loaded in GSAK, you should see a screen similar to this (there will be 
differences due to customisation I have done which will be discussed below.) 

 

Figure 11 - Main Screen 

IMPORTANT The screenshot above may look different from what you will actually see 

depending on the version which is installed, whether there are specific 

toolbars shown and which particular columns are shown.  Setting of 

columns will be discussed below. 

5.1 Split Screen 

As can be seen the Split Screen Area now shows details of the cache and also a map of the location 
of the cache.  There are other split screen options which can be changed by using the following 
button: 

 

Figure 12 - Split Screen Format 

A useful one that you can have is Dual Map (this is a separate download called HTML_DualMap from 
the GSAK Macro Index) which shows a Google Map and SteetView – below is an example of what is 
shown for this event. 
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Figure 13 – DualMaps 

The split view can be switched on and off by pressing the F2 button. 

5.2 Code Colouring 

The Code field is coloured to help you easily identify types of caches.  The colours are defined in the 
options – see Figure 2 - General Options.  These colours also colouring used on the status bar – see 
Status Bar. 

5.3 Child Waypoints 

Child Waypoints are additional waypoints to the main coordinates.  These can be published by the 
cache owner or can be defined by the user.  The types of child waypoint that can be configured are: 

 Final Location 

 Parking Area 

 Question To Answer 

 Stages Of a Multicache 

 Trailhead 

 Reference point 

You can easily identify a cache which has additional waypoints as they are shown in bold within 
GSAK. 

 

Figure 14 - A Child Waypoint 

The information of the child waypoint is shown in the split screen. 

 

Figure 15 - Child Waypoint detail 
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5.3.1 Grab Coordinates 

There is a very useful macro called GrabLogCoordinates.gsk which simplifies the grabbing of 
coordinates from log text and from cache descriptions and automatically adding them as child 
waypoints.  This is very useful for any corrected coordinates in logs or for adding child waypoints 
which are in the cache description.  

For example, http://coord.info/GC1ZCXG Clodeeclogs#1  has the following in the text: 

Additional Waypoints 
CA1ZCXG - Parking area 

N 53° 03.257 W 001° 19.781 
Flat area by the kissing gate 

The macro will add the following: 

 

Figure 16 - Child Waypoint example 

5.4 Views 

GSAK has been written so that you can configure it to look how you want – this allows you to view 
the information which you want to see.  Multiple views can be created and selected as and when 
required. 

A view is defined by the selection of columns you decide upon, the order, width and name of those 
columns.  The first column can be locked in place to make it always stays in view. 

 

Figure 17 – Columns 

Once you define a view, you can save it and then recall it at any time.  You can even get a particular 

view to be the default for different databases. 

http://coord.info/GC1ZCXG
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5.4.1 Selecting Columns 

To add to the default columns, you have to go to the Menu bar and select Tools->Options and then 
select the Display tab. 

 

Figure 18 - Adding Columns 

5.5 Status Bar 

The Status bar now contains a lot of useful information. 

 
This tells you whether there is an active 
filter.  If you have a filter active, you will see 
something like: 

 

 
If no filter is active, it shows the total 
number of waypoints in the current 
database. If you have a filter active, you will 
see something like: 

 
 

 
This shows the name of your current centre 
point.  All distances and bearings are 
calculated from this point. To set any 
waypoint as the centre point, right-click the 
required waypoint and choose Set this 
cache as centre point.  If you want to set 
this to your Home coordinates, click the 
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 icon on the toolbar. 

 
This shows the counts for the caches you 
have found, not found, or placed; and the 
number of archived caches in the current 
database.  These counts reflect totals 
according to the current filter. 

You can double-click on any of these counts 
to set a filter based on the corresponding 
total (ie double click on the yellow 6 and 
only those caches you have found will be 
shown) 

5.6 Grid Area 

The grid area is where you see the information regarding the caches within your filter (if active).  The 
columns which are shown can all be customised and then recalled whenever required.  This is 
achieved by going to your Menu bar and selecting View->Add/Remove Columns. 

Useful columns to have are 

 
This is the unique GC code given by Geocaching.com.  However it will be coloured 
according to the status of the cache, using the same colours as used on the status 
bar. 

There is a priority of colours which are used and can be changed via the options.  
This is sometime useful if you always want to see a particular colour for your finds 
for example. 

 This indicates the type of the cache (Traditional, Multi, Event, etc) 

 
This column indicates the waypoint has a travel bug (according to geocaching.com) 

 
This is the user flag.  If you want to filter a set of caches quickly, you can click on this 
column for a cache and then press F8 to only show those caches. 

 This column indicates the status of the last four logs for that cache.  The colurs have 
the following meaning: 

Green = Found or owner maintenance 
Red = Not Found 
Grey = No log yet 
Yellow = Needs archiving or Needs maintenance 
 

 
This means that there is a user note attached to the cache.  To create a user note, 
double click on this column and a dialog will open up.  This allowas you to store 
information on the cache – especially useful for holding information on solving 
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puzzles or for bonus caches. 

The log section of the Notes is not really used now and is better dealt with by 
means of Publish Logs which is discussed in 9.3. 

 
This indicates that a cache has a set of corrected coordinates.  Once you have 
solved a puzzle, you can set a corrected coordinate and this will be used as the 
cache location when you export the information from GSAK.  See 7.2.2 for more 
information about this. 

5.7 Sorting 

If you wish to sort the information in front of you, click on any column heading, the grid will be 
sorted on that column. Click again to have the sort sequence reversed.  Multi column sorting (2 only) 
is also supported. GSAK will use your last selected sort as your "secondary" sort sequence. For 
example, if you want to sort caches by container type then distance and then first click on the 
distance heading and then click on the container heading. 

 

Figure 19 – Sorting 
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6 Filtering 

IMPORTANT Filtering can only work with the information that is held within your 

database.  If you do not have the logs in your database, you will get 

“wrong” caches filtered.  See section 9 for how to ensure that logs are up 

to date. 

Filtering is one of the most powerful parts of GSAK.  It allows you to take a large database and find 
the information you want without harming the overall database.  For example, if you wished to find 
all caches by northking which are available and within five miles of this event, you cannot create a PQ 
to do this but it is very simple in GSAK. 

 

Figure 20 - Filters 

You can set up a new filter in one of two ways.  The first is to click on Menu->Search->Filter as shown 
on the left in Figure 20 - Filters and the other is to click on the magnifying glass on the tool bar, as 
sown on the right.  If you decide to cancel a filter, you press the red X as shown above.   

As with views, you can save filters for later use. 

6.1 General Tab 

 

Figure 21 - Filter - General Tab 
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Field Description 

Select a Saved Filter Allows you to open a previously saved filter configuration. 
Click on the drop down arrow on the right of that field to 
view the list of previously saved filters. 

Cache Name Allows you to search for a cache by name or partial name.  

Reverse Filter Allows you to take a pre-existing filter and reverse it.  For 
example, if you have a filter which only showas caches which 
have been found, using this will show only caches which you 
have not found. 

Full Text Search Allows you to search for a string of text in a saved cache page 
or the areas which you seletc.  The Highlight HTML tick box 
will highlight the search term in the Split Screen. 

Distance Allows you to filter by distance from your chosen center point 
up to the maximum circumference of the database. 

Found Status Should be self-explanatory  

Placed By This is whatever the cache owner puts in the placed by field 
and it is not necessarily the same as Owner Name. 

Difficulty and Terrain Should be self-explanatory  

Available Status Should be self-explanatory  

User Flag Allows you to filter by the user selectable flag.  A User Flag 

allows you to mark any waypoint with a user flag (just click in 
the box).  You can then set filters on this flag (F8).  This 
allows you to select or exclude individual waypoints in your 
filters.  This comes in very handy when you are creating a 
filter for export.  To clear an individual user flag, just click on 
the box again. 

User Data These are fields where you can store information or keywords 
to filter out later. For example if a cache is in Wollaton Park, 
youc an add this into a user data field and then filter on 
them. 

Has User Notes GSAK allows you to add your own notes for individual 
waypoints in the database. This is discussed in section 7.2.1 

Travel Bug Name Should be self-explanatory  

Source This column indicates where your data came from – GSAK can 
understand data which has come from Geocaching.com, 
Terracaching.com and Opencaching.com for example. 

Premium Only Allows you to filter Premium only chaches 
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Favorite Points Allows you to set a filter on the required number of favorite 
points allocated to cache 

 

6.2 Dates Tab 

This tab gives you a lot of control over searching with dates which is often useful when undertaking 
challenge caches which have date specific requirements. 

 

Figure 22 - Dates Filtering 

6.3 Other Tab 

 

Figure 23 Filtering Others Tab 
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The most useful options on this tab are the cache types; the container size, the Country, State and 
County and corrected coordinates.  Corrected coordinates can be either puzzles you have   solved, or 
taken from caches where the posted coordinates are listed as off and other cachers have logged 
updated coordinates for the cache. 

Also useful is the “My Find Count” as it quickly allow you to find caches where you have accidentally 
logged two finds (although there are caches such as Ye Olde Survey Monument (http://coord.info/ 
GC45CC which may multiple found logs). 

6.4 Examples 

Let’s say, I needed to find all caches owned by northking which were puzzle and which had either a 
regular cache container or was marked as “other”.  I would open up the Filter dialog and set the 
following on the General tab: 

 

Figure 24 - Filter on Owner Name 

And the following on the Other tab 

 

Figure 25 - Filter on Cache and Container 

Note GSAK highlights what has been changed and also highlights which tabs 

have been changed. 

This would result in the following: 

 

Figure 26 - Filtered Results 
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Figure 27 - Status Bar 

Note that the status bar shows all of the information but restricted to the filter information. 

Now let’s say that I want to go for a caching expedition with a couple of other cachers  but we only 
want to try to find caches that each other has not already found.  Simply go to General tab and set: 

 

Figure 28 - Found Status 

And then go to the Logs tab and set: 

 

Figure 29 - Logs to search 

And  

 

Figure 30 - Logged by 

You can have up to 5 people in the details section – simply separate them by a ; (semi colon). 

Note  It is only Found logs which are excluded – spire67 and northking may 

have posted a DNF or a Note on the cache page but that does not mean 

they have found it! 

6.5 Caching along a route 

Although there is a cache along a route PQ option on Geocaching.com, this is a far more flexible 
option as it allows you to specify a straight line or a multi-segment curved line or a polygon shape , 
and a distance from the line.  If you go to Search-Set Filter and then choose the Arc/Poly tab and 
then click on  

 

Figure 31 - Arc/Poly drawing 
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You will be shown a map which is based around the center point of your current database.  If you 
click on the “Draw a line tool”  you can click on the map to place a point and double click (or finish 
the polygon) to create the route. 

 

Figure 32 - Arc/Polygon Route Planning 

Notice that GSAK create a list of coordinates which match the route.  Once you are completed, you 
press the “Send to GSAK” button on the coordinates will be automatically added to the filter window. 

When this is done, you can also select the distance in Miles (depending on your settings) either side 
of the line you also wish to include in the filter. 
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7 Databases 

GSAK stores your cache information in a database. When first starting GSAK it creates a default 
database, which it calls "Default".  You could use this for all your caches as it would be possible to 
holds tens, if not hundreds,  of thousands of waypoints in it. 

However, it may be easier to manage and keep up to date multiple databases.  You can create 
additional databases if you wish, and you can call them names that mean something to you.  For 
example, you might create a database for the waypoints near your home and another for near your 
work.  They could be called Home and Work. 

I would also recommend a database which is simply used to hold your finds as there is a number of 
very useful macros which expect to have a separate “Finds” database. 

7.1 Create a database 

To create a database go to the Menu Bar and select Database-New.  You will see the following: 

 

Figure 33 - Create a database 

You give a name that is meaningful to you.  You can also set default views, sort sequence and centre 
point for this specific database.  This is where the power of views can come into itself. 

You can now change databases either by selecting the Menu bar Database->Select or Via the 
Database dropdown on the Tool bar. 

7.2 Adding data to the database 

You can add data to the new database either by a PQ, a locally stored GPX/ZIP file or via the API as 
shown in sections 4.1 and 4.2. 
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7.2.1 User Notes 

User notes are extremely handy for storing information about a particular cache and come into their 
own when working with puzzle caches.  If you select a cache and right click on it, you will see the 
following: 

 

Figure 34 - Cache Right Click Options 

If you select “Add/Change/Delete Note…” you will be shown the following: 

 

Figure 35 – Notes 

In the user notes section, you can put anything you want and it will be saved in the database.  I 
personally use it to save information when working out a puzzle. 



Speed Caching Event - Hints and Tips 
(http://coord.info/GC4291W) 

 

 

GSAK Introduction and Tips.docx Page 29 of 43 

 

NOTE:  With the release of V8 of GSAK and the Groundspeak API, the "log 

section" of the user notes is now deprecated. I would recommend you 

use the new "Publish logs" feature, and enter all your log text there.  

Further information can be found at 9.3  

7.2.2 Corrected Coordinates 

Once you have solved a puzzle, it would be a good idea to have the location of the final cache within 
the database.  It is best to use corrected coordinates here as Groundspeak inconsistently provides 
corrected coordinates or original coordinates, depending on how you obtain the data (e.g. Pocket 
Query vs. Geocaching.com access (API)). 

This means that if you load corrected coordinates posted online at geocaching.com, GSAK simply 
updates the coordinates for the cache (i.e. GSAK cannot distinguish between changed coordinates 
and corrected coordinates).  In other words, there are no corrected coordinates in GSAK using this 
approach (which is why GSAK would not show the corrected coordinates indicator). 

NOTE If you use Corrected Coordinates in GSAK, the will not be overwritten by 

any changes made on the Geocaching.com. 

To use corrected coordinates, right click on the cache you wish to change and you will be shown the 
following: 

 

Figure 36 - Corrected Coordinates 

NOTE The coordinates shown above are made up and are NOT the correct 

coordinates for the cache – please do not go there! 

Once you have put in corrected coordinates, GSAK will update the map in the split screen as shown 
below.  The cone signifies the original position of the cache, the question mark in the balloon shows 
where the corrected coordinates are (The blue P shows a parking waypoint). 
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Figure 37 - Map showing corrected coordinates 

7.3 Exporting Data 

Once you have the data in GSAK, it would be helpful if you could export this to your GPSr or 
smartphone and GSAK has the ability to export data files to several other applications formats. 

To export in one of these formats click on Menu->File and select “Export” as shown below. 

 

Figure 38 – Export Data 

NOTE GSAK will export whatever information is in the active filter – if you wish 

to export the entire database, ensure that there is no filter set. 

7.4 Send Waypoints 

In addition to exporting, GSAK has the ability to send information directly to many GPSr devices.  To 
facilitate this, you must setup the configuration of the GPSr.  This is done via the Menu->GPS option: 
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Figure 39 – Configure GPS 

You are then shown the following: 

 

Figure 40 - GPS Setup 

There are many options dependent on the GPSr you have.  There are also macros which are GPSr 
specific which add additional features. 

Once you have set up GSAK to know which GPSr you have, you can do Menu->GPS->Send Waypoints 
and you will be shown the following. 

 

Figure 41 - Send Waypoints to GPSr 
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By default the “Use defaults” option is ticked.  However, if you change this, you will have more 
control over what is actually sent to the GPSr.  As with mostly everything in GSAK, “Send Waypoints” 
will send what is contained in the current filter. 
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8 Configuring the Toolbar 

GSAK contains a user configurable area called the Tool Bar or Speed Bar. Tool buttons (such as the 
filter and file open) buttons perform the same functions as if you clicked on a menu item and chose a 
function under that drop down menu. The buttons are a sort of quick launch function. To change the 
tool buttons Right click in any open space not currently occupied by a button and select “Customize 
Tool Buttons” from the menu.   

 

Figure 42 - Customise Toolbar 

 

The section highlighted in red in the figure 
to the left shows the various categories of 
speed bar buttons. 

The section highlighted in black show you 
the available speed bar buttons for the 
highlighted Category. 

You may add, remove, and change position 
of any of the buttons. Buttons are available 
for almost all menu options, plus there are 
buttons for custom URLs and Macros. 

 

To add a speed button, simply click on it and drag it up to the speed bar area and drop it. To remove 
an unused speed button click on it and drag it back to the dialog box. In addition while the Customize 
Speedbar dialog box is open, you can move and arrange any buttons on the speedbar. When you are 
finished editing the speed bar, click “OK” in the Customize Speedbar dialog box. 
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9 Geocaching.com API and GSAK 

One of the major changes with version 8 of GSAK is that it is integrated with the Geocaching.com API 
(Application Programming Interface).  This is simply a way to connect directly to the Geocaching.com 
website and ask it for information which will then be returned to GSAK. 

The benefit if using the API is that it allows you to get more information in  addition to any PQs you 
have set to run on Geocaching.com as well.  For premium members the limits are currently 6,000 full 
caches per day (and also 10,000 "lite2" caches). For non premium members the limits are 3 full 
caches per day (and 10,000 "lite" caches) . 

9.1 Authorising GSAK to use Geocaching.com 

To start to use the API, you must authorise your copy of GSAK with your Geocaching.com account.  
This is simple and only needs to be done once if you only have a single account.  If you have more 
than one account, GSAK supports up to a maximum of five Geocaching.com accounts for use with 
the API. 

When you authorise your first username, you will see the user name you logged in as at the very 
bottom of your Menu->Geocachingc.com access menu with a check mark on the left hand side (to 
indicate this user is "active"). 

When you authorise your second (or subsequent) username,  you will see another user added to this 
menu. 

Now you can swap users by simply selecting the user from this menu - you won't be asked to log into 
Geocaching.com again.  

At any time you can take the main menu option "Geocaching.com access" to view the currently 
selected user (the one with a check mark alongside it) 

To authorise a user, simply select Menu->Geocaching.com access->Get Geocaches.  You will then be 
shown a dialog which informs you that the process will contact Geocaching.com but that GSAK does 
not store this information.  

You are then shown the following: 

                                                             
2 A full cache can be seen as being the same as having the same information as a .GPX file (ie contains logs etc) 
and a lite is similar to a .LOC file. 
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Figure 43 - Geocaching.com Login 

Once you have entered your information, you will see the following: 

 

Figure 44 - Allow Access 

Once you press “Allow Access” you are authorose.  You will also get an email sent to the email 
address which Geocaching.com has for you as confirmation. 

9.2 Get Geocaches 

Once you are authorise, you are able to get information from Geocaching.com.  Get Geocaches is 
discussed in section 4.2. 

9.3 Publish Logs 

A lot of GPSr and smartphones have the ability to create what is called a field note.  This field note 
contains information about the date/time you found/did not find a cache and also the notes that you 
wrote at the time. 
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This file is normally called geocaching_vists.txt or fieldnotes.txt and if you can get this from your 
GPSr/smartphone and onto your PC, you will be able to use GSAK’s ability to automatically publish 
logs and significantly reduce the time taken do log caches manually. 

If you have go to Menu->Geocaching.com->Publish Logs, you will see the following (the menus are 
shown by either right clicking in the box or by pushing the Fetch button): 

 

Figure 45 - Publish Logs - Fetch 

Once you have loaded some file, you will see something similar to the following: 

 

Figure 46 – Publish Logs – Populated Grid 

If an entry is not bold, it signifies that you have not written any descriptive text in the field notes 
section when you “logged” the field note at the time of finding the cache. 



Speed Caching Event - Hints and Tips 
(http://coord.info/GC4291W) 

 

 

GSAK Introduction and Tips.docx Page 37 of 43 

 

9.3.1 Publish Logs Settings 

Before we actually publish some logs, it is important to understand some of the settings.  If you click 
on the Settings tab, you will see something similar to:  

 

Automatically Apply Templates - This option is the default 

and recommended.  Templates are discussed below. 

 

Normally you would only want to work with unpublished 
logs (the default). However, GSAK saves all your logging 
history so you can review old published log entries by 
unchecking this option. 

 

Select this option to have any field notes automatically 
update the GSAK user notes or Log sections.  This is the 
same as Waypoint->Add/Change/Delete Notes 

 

This option is would normally be used when you fetch from 
GPSr. Check this option to have the field notes file removed 
after the fetch has been done.  It is safe to use this as long 
the Archive option is shown (see below) 

 

This automatically gathers your current found number at 
Geocaching.com and then updates templates with the 
information. 

 

If you opt to keep your file after a fetch then you may want 
to use this option to ignore older logs in this file so they 
don't get loaded again. 

 

Use of this option would normally be in conjunction with 
the “Delete file after fetch” option. GSAK will take a backup 
of this file and place it in your [application data] folder (you 
can find this folder using "File=>Folder finder"). The backup 
file is named YYYYMMDDHHMMSS_FileName where YYYY 
= Year, MM=Month, DD = day, HH = Hour, MM = Minute, 
SS=Seconds, and FileName is the original file name. 

 

GSAK supports abbreviations that will be expanded to the 
full version in your field notes. This means that you can 
write REPLOG in a field note and GSAK will automatically 
(using this example) change the text to “Replaced Log.  
Have original if CO requires it. 

9.3.2 Templates 

The use of templates enables you to have standard boiler plate text for each log type. These 
templates can just be literal text, but are more useful if you include dynamic information - which we 
refer to as %tags. 
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The dropdown box in the middle allows you get to select what type of log your template applies to. 
As we have ‘Found it’ selected whatever we type in the box below will be applied to every cache that 
we find. 

 

Figure 47 – Templates 

An example of the type of information you can put in is: 

 

Figure 48 - Template Example 

And when you click on the preview tab, you will see something like: 

 

Figure 49 - Populated Template 
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9.3.3 Logging 

Now that we have field notes and templates set up it is now time to actually log something  

 

Figure 50 - Publish Logs Main Screen 

The important areas on this screen are the ability to add a favourite point on a particular cache; add 
any coordinates you may have for the cache; the actual field notes area which you can change and 
the ability manage trackables and images when posting a log for a cache. 

You can also mark a particular cache as a FTF. 

Trackables 

It is very easy to manage trackables within the Publish Logs dialog.  Once you have pushed the 
button and then right clicked on a particular trackable, you are shown something similar to: 
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Figure 51 – Trackables 

Once you have selected an option, you will be prompted to leave a note and then the screen will be 
updated to show the action being taken for each trackable. 

If there is a trackable in a particular cache, you will see it on the right hand side of the screen above.  
If you right click on a trackable here, you will be offered to Discover, Write Note or Retrieve the 
trackable.  You will be prompted to enter the tracking code for the trackable. 

Images 

If you wish to add an image to a particular cache, press the Images button and then click Add.  You 
will be prompted to find the photo which you wish to upload.  You can add a caption for the photo 
and a description. 

NOTE Geocaching.com has a limit of about 3Mb for an image and GSAK will 

show the following error if you try to upload a picture bigger than this.  

You will have to resize the picture to be under 3Mb in size. 

 

Publishing 

Once you have completed all of your logs, you will actually want to send the information to 
Geocaching.com.  There are two options which you can take: 

 Publish All.  This does what it says and publishes all of the caches in the Publish Logs dialog. 
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 Publish Selected.  If you select a few caches to publish (say a particular day’s caching), only 
these will be sent to Geocaching.com.  GSAK is intelligent enough to understand about cache 
runs (Cache #%Count - %Time[t]. The %RunCount%Suffix of %RunTotal caches found today in 
the template) and will make sure the numbers are correct. 

 

When you press either of these button, you will see something similar to the following: 

 

Figure 52 - Publish Logs Confirmation 

Note You should check that the user name is correct and that you are 

uploading the correct number of logs, images and trackables before you 

press Yes. 

9.3.4 Refresh cache data 

This is a very useful option if you are intending to go out caching or even if you simply wish to keep 
your database up to date.  This option is used to get the latest information for caches in your 
database/filter directly from the Geocaching.com web site.  

Note: This option has a limit of 2,000 caches per hour and 6,000 caches per 

day (for Full details) and 10,000 caches per day (for Light). It uses the 

same API call as Get geocaches and hence is bound by the same limits.  

In addition, the API only gets the number of logs requested and unlike a 

PQ you are not guaranteed to get your log unless it is in the number of 

logs retrieved. 

9.3.5 Get recent logs 

This option is very useful if you wish to have a lot of logs for a particular cache (you could get 9,999 if 
you really wanted!).  This is handy if you have downloaded a PQ and then wish to get more logs. 

9.3.6 Status Check 

This is a very quick check for the status of a cache or filter.  This is quicker than downloading cache 
data and actually does not impact your download balance for API usage. 
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10 Macros 

Macros are a programming language that allow to extend the functionality of GSAK.  They are out of 
scope of this document but there are plenty of macros which are already written.  If you press Menu-
>Macro, you will see something similar to the following: 

 

Figure 53 – Macros 

If you click on the blue “Online Macro Index” you will be taken to an area where macros written by 
others are stored. 

10.1 Useful Macros 

The following are particularly useful macros which you may find helpful. 

HTML_GoogleMapsNearest
V3 

This is used in the split screen and shows a Google map showing 
caches near currently selected cache 

HTML_Google_Map_Elevati
on 

This is used in the split screen and shows a Google map with elevation 
profile of interactively defined path 

HTML_DualMap This is used in the split screen and shows Google Map and SteetView 
as shown in Figure 13 – DualMaps 

HTML_GoogleMapsNearest This is used in the split screen and shows a map of the nearest caches 
to the elected cache. 

HTML_WideView This is what I use as default.  It is an optimised split screen view. 

myGMEv3 Google Maps Export.  This shows a map in your browser which has a 
list of the caches in your filter. 

FindStatsGen Does pretty much whatever you want for generating statistics which 
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can then be used on your geocaching.com profile.  Have a look at 
http://www.geocaching.com/profile/default.aspx?u=The%20Tares%2
0Clan for an example of what can be done. 

GetCachesOnRoute This is a route generation and boxing macro which uses the API to get 
caches along a route. It does this by dividing the route into a series of 
rectangular boxes and then grabbing the caches within each box. 

CacheRoute3 This creates an optimised driving or walking routes for a series of 
caches. 

GrabLogCoordinates  This simplifies the grabbing of coordinates from log text and from 
cache descriptions and automatically adding them as child waypoints. 
An example of the output can be seen  in Figure 16 

 

http://www.geocaching.com/profile/default.aspx?u=The%20Tares%20Clan
http://www.geocaching.com/profile/default.aspx?u=The%20Tares%20Clan
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